Users of Microsoft add-ins (not just CloudExtend) may encounter issues loading them. We've gathered these tips from Microsoft to help you troubleshoot the error below.

The solution depends on a combination of the version of your Windows OS and your Outlook which determines the browser used to render all of your add-ins (this is entirely different than your default browser and will either be Internet Explorer or Edge).

Refer to this article from Microsoft to determine if your browser is IE or Edge.

If your browser is determined as Edge

Users on updated versions of Windows 10 and Microsoft 365 typically have Edge used to render their add-ins and it is possible that the Desktop App Web Viewer is corrupted. Take the steps below to reinstall it.

  1. Close Excel

  2. Run the following cmdlet in Windows PowerShell or command line on your PC, with Admin permissions:
    powershell Add-AppxPackage -register -disable c:\windows\SystemApps\Microsoft.Win32WebViewHost_cw5n1h2txyewy\AppxManifest.xml

  3. Restart Excel and load CloudExtend

If your browser is Internet Explorer

Microsoft renders add-ins using Internet Explorer for users on older versions of Windows and Outlook.

Upgrade

Per the Microsoft article referenced above users should upgrade to Windows 10 version 1903 or higher and Microsoft 365 version 16.011629 and higher.

Enable Protected Mode in the Internet Properties

If upgrading is not an option then enable protected mode in Internet Explorer. Even thought your default browser is not Internet Explorer note that Microsoft leverages Internet Explorer for users on specific combinations of Windows and Office versions.

  1. Close Outlook and all your browsers.

  2. Open Internet Explorer.

  3. Click Tools.

  4. Click Internet Options.

Alternatively, for steps 2 to 4; you may also access the Internet Properties through the steps below:

  1. Press 'Windows logo' key + R on your keyboard.

  2. Enter inetcpl.cpl ten press Enter key.

  1. Click Security tab.

  2. Select Internet Sites zone.

  3. Select Enable Protected Mode (make sure box is checked).

  4. Click OK.

  5. Restart Internet Explorer and Outlook.

  6. Try to reproduce the issue

  7. If the issue persists reboot your computer and try again

Did this answer your question?