Getting a white screen when trying to enter your two-factor authentication code when logging in to NetSuite? We can help.
Symptoms
When a user enters the account details and password while trying to log in to a CloudExtend application with NetSuite two-factor authentication the page may hang up preventing the user from entering their verification code.
Causes
There are two reasons for this happening. It's important to note that all Microsoft add-ins (not just CloudExtend) are rendered using a specific browser. Microsoft chooses this browser based on the combination of your Windows OS and your Microsoft Office software version. This may not be the same browser you use for day-to-day activities as it is beyond your control (and ours).
NetSuite has stopped supporting Microsoft Internet Explorer web browser versions along with their 2021.2 updates. Many older combinations of Windows, Outlook, and Excel all render add-ins with the older Internet Explorer, hence when the add-in connects to NetSuite it is rejected. The new web browser versions that are supported by NetSuite rely on the latest JavaScript version, ES6 as well.
Microsoft has stopped supporting the Internet Explorer and Edge Legacy web browser versions and has transitioned to their new Chromium-based Edge web browser versions. Even though you may not be using Chromium Edge as your default browser (i.e. you may use Chrome) Microsoft will still render all add-ins using their Chromium browser (for add-ins this is called WebView2).
Therefore, if your combination of Windows OS and Office is causing Microsoft to render add-ins in an older browser you should upgrade your OS and Office to the latest version to ensure WebView2 is used.
Workarounds
To check if you have WebView2 installed on a computer, go to Settings > Add or remove programs and then search for WebView2 in the search box. You should see something like the following screenshot.
If you don't have it keep reading.
Update your Windows and Office
Most users will need to update their operating system and Microsoft Office versions to the latest versions so that they will start using WebView2 by default. Shortly after Office version 16.0.13530.20424 or later is installed on a computer (usually within 24 hours), WebView2 is automatically installed if it isn’t already.
Still no WebView2 24 hours after updating Office?
In case the issue persists even after the updates are installed, please download WebView2 and/or set it as the default rendering component.
📌 Users can download WebView2 from the Webview2 page on the Microsoft site.
Step 1: Admins at these customers will need to take an additional step to enable the use of WebView2.
💡 Note: Customers on the Semi-Annual Enterprise channel of Office can expect to receive version 2102 in July 2021.
They must create the registry key HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\WEF\Win32WebView2 and set its value to dword:00000001.
If the WebView2 control is not installed (or the registry change is not made where needed), then add-ins in subscription desktop Office will run in either the older WebView control called EdgeHTML or just “WebView” (also known as “Spartan”), or the “Trident” WebView control that originated with Internet Explorer 11. For details, see Browsers used by Office Add-ins.
For more information, click here for an article from Microsoft with full details.
Step 2: If you're still having trouble, contact our support team or use the online version of Microsoft Excel or Microsoft Outlook.