Organizations that use shared mailboxes (e.g., sales@yourcompany.com, support@yourcompany.com) can also take advantage of the Send from Outlook feature in ExtendSync.
This allows users to send emails from a shared mailbox address directly within NetSuite, while messages are still logged in both NetSuite and Outlook.
Requirements
To use Send from Outlook with a shared mailbox, ensure the following:
Requirement | Description |
Licensed ExtenSync user | The employee must have an active ExtendSync license assigned to their Outlook email. |
Licensed shared mailbox | The shared mailbox address (e.g., sales@yourcompany.com) must also have an ExtendSync license. |
Same Microsoft 365 tenant/domain | Both the employee’s Outlook account and the shared mailbox must belong to the same domain and tenant. |
Admin Guide: Configuring Shared Mailboxes for Send from Outlook in NetSuite
This section is for NetSuite administrators who will set up shared mailbox permissions for users.
NetSuite admin need to configure the following:
Step 1: Search for record Celigo Send from Outlook Email Config.
Step 2: Click New Celigo Send from Outlook Email Config button.
Step 3: This will let you set the employee and in the backend checking if the domain or tenant is the same.
Example Shared Mailbox Configuration:
Employee | Preferred Email (From) | Shared Mailbox Email | Status |
Barry | ✅ Accepted. Same domain (@cloudextend.io) | ||
Jane | ❌ Rejected. Domains do not match |
💡 Tip:
If multiple employees use the same shared mailbox, each one must be configured individually in Celigo Send from Outlook Email Config to enable the feature..
Step 4: Once this is configured, emails will be sent using Send from Outlook button will reflect the email inside the From field in the Recipients tab.
Step 5: After sending, the email will reflect in the following:
NetSuite, under Communication> Messages tab of the related record.
Outlook, Sent Items of shared mailbox
Common Error
Preferred and shared email domains are not the same or tenants are not the same
Error Message:
Preferred and shared email domains are not the same or tenants are not the same.
Cause:
The employee’s Outlook email domain or Microsoft 365 tenant does not match the shared mailbox’s domain/tenant.
Solution:
Verify the user’s employee record in NetSuite.
Ensure both Preferred Email and Shared Email use the same domain and belong to the same Microsoft 365 tenant.
Update and save the configuration again.




