Issue
The Email using CloudExtend button is not visible to users in NetSuite records, although it is visible to the admin.
Cause
Users assigned to custom roles in NetSuite lack the necessary permissions for the button to appear.
Resolution
NetSuite admin needs to add the permission below:
Step 1: In NetSuite, go to Setup > User/Roles > Manage Roles and and select the relevant custom role.
Step 2: Go to Permissions > Custom Record Tab.
Step 3: Add Celigo Send from Outlook Email Config and set to FULL.
Step 4: Save.
Might take a couple hours for the permission to propagate into the role.
Advise user to login and check after 2 hours.