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Troubleshooting: Email using CloudExtend Stuck at Spinning Page

ExtendSync Outlook | See how to resolve Email using CloudExtend loading stuck at Spinning page

Updated this week

Issue

When using the Email via CloudExtend button, the page remains stuck on the loading spinner.

CloudExtend is preparing your new email experience... screen.

Cause

This issue usually occurs when users are assigned custom NetSuite roles that lack the required permissions for the Send from Outlook feature.

Without these permissions, the feature cannot properly initialize and remains stuck on the loading spinner.

Resolution

A NetSuite Administrator must update the user’s role permissions to enable the feature.

Step 1: In NetSuite, go to Setup > User/Roles > Manage Roles and and select the relevant custom role.

Step 2: Go to Permissions > Lists

Step 3: Add Track Messages and assign FULL access level.

Step 4: Go to Permissions > Custom Record Tab.

Step 5: Add Celigo Send from Outlook Email Config and set to FULL.

Step 6: Save changes.

Might take a couple hours for the permission to propagate into the role.

Advise user to login and check after 2 hours.

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